IMA light and check engine light and flashing "D" - GreenHybrid - Hybrid Cars


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-03-2005, 06:34 PM
Enthusiast
Thread Starter

 
Join Date: Aug 2005
Posts: 15
Default IMA light and check engine light and flashing "D"

Hopefully someone here has seen this before.

After only 200 miles on my 05 HCH, I see the IMA light, check engine light and the D for Drive light is flashing. The battery guage is blank and the radio doesn't work.

Also, when the ignition is off, the keyless entry does not work, the doors won't even lock with the lock.unlock switch.

I checked every fuse under the dash and under the hood, and my front battery is fine.

I do have an appointment next week, but thought maybe someone here would be able to save me a trip to the dealer.



Thanks
Reply With Quote
  #2  
Old 09-03-2005, 06:48 PM
tbaleno's Avatar
 
Join Date: Dec 2004
Location: Leominster, MA
Posts: 2,157
Default Re: IMA light and check engine light and flashing "D"

I think there is a single fuse near the battery that isn't in one of the fuse boxes. Look at this picture http://memimage.cardomain.net/member...28_12_full.jpg

Look just below the fuse box and to the right of the battery in that picture.
Reply With Quote
  #3  
Old 09-03-2005, 07:11 PM
AshenGrey's Avatar
Hybrid True Believer

 
Join Date: Aug 2005
Location: Baltimore, MD
Posts: 881
Default Re: IMA light and check engine light and flashing "D"

I had a similar problem once. It turned out to be a software glitch. On my car, the IMA, CE, and Battery light all lit up, and the IMA showed no charge. The dealer was able to fix it in under an hour.
Reply With Quote
  #4  
Old 09-03-2005, 07:24 PM
tbaleno's Avatar
 
Join Date: Dec 2004
Location: Leominster, MA
Posts: 2,157
Default Re: IMA light and check engine light and flashing "D"

Maybe just disconnecting the battery for a few minutes might clear the problem.
Reply With Quote
  #5  
Old 09-03-2005, 09:00 PM
Enthusiast
Thread Starter

 
Join Date: Aug 2005
Posts: 15
Default Re: IMA light and check engine light and flashing "D"

Tried the battery thing, didn't help.


I located the little fuse box by the battery, I did see a blue engine picture, but I can't tell if that "fuse" is bad or not. There is no window to see anything inside.


Thanks for the suggestions.
Reply With Quote
  #6  
Old 09-03-2005, 09:08 PM
tbaleno's Avatar
 
Join Date: Dec 2004
Location: Leominster, MA
Posts: 2,157
Default Re: IMA light and check engine light and flashing "D"

pull it out and replace it anyway Fuses are cheap. if it fixes your problem toss the fuse you pulled. If not keep it as a spare.
Reply With Quote
  #7  
Old 09-03-2005, 10:30 PM
Conservative Socialist

 
Join Date: Feb 2005
Location: Phoenix, AZ
Posts: 878
Default Re: IMA light and check engine light and flashing "D"

If the check engine light is FLASHING, you're supposed to immidiately shut down the car and have it towed to the dealer. They can actually void your warranty if you drive with the CEL flashing. Good luck anyway.
Reply With Quote
  #8  
Old 09-03-2005, 10:32 PM
Enthusiast

 
Join Date: Aug 2005
Posts: 12
Default Re: IMA light and check engine light and flashing "D"

According to the Service Manual " When the Transmission Control Module (TCM) senses an abnormality in the input or the output systems, the D indicator (A) in the gauge assembly (B) will usually blink."

A table that starts on 14-7 of the manual list a whole multitude of malfunctions that cause the indications you described.

Hope it's nothing too serious.

Last edited by NOTU; 09-03-2005 at 10:36 PM. Reason: spelling
Reply With Quote
  #9  
Old 09-04-2005, 09:36 AM
Ridiculously Active Enthusiast

 
Join Date: Jun 2004
Location: Phoenix, Arizona
Posts: 550
Default Re: IMA light and check engine light and flashing "D"

I am will AZCivic. Don't play around with it or you chancing voiding the warranty. I am not sure why the dealer would take it immediately though. Have tried to call Honda?
Reply With Quote
  #10  
Old 09-13-2005, 12:42 AM
Enthusiast
 
Join Date: Sep 2005
Posts: 2
Default Re: IMA light and check engine light and flashing "D"

I have the same problem on my 03 honda civic hybrid 30k after I replaced the radiator. I don't know what to do, but my windows and alarm started to work when I checked and tighted/connected all the wires. Hovewer, the D is still flashing, check engine is on, and stereo isn't working. What else can we do?
Reply With Quote
 
 
Reply

Related Topics
Thread Topic Starter Forum Replies Last Post
Check Engine light, Battery light, IMA light come one cak615 HCH I-Specific Discussions 2 10-28-2013 09:11 PM
Check Engine + IMA light...then IMA goes off? cazort HCH I-Specific Discussions 5 10-28-2013 09:07 PM
IMA light & Check engine light question hulagirl HCH II-Specific Discussions 1 01-17-2013 12:04 PM
HCH 2003 with 180K miles Engine Hesitates...Check Enginer light and IMA light on funnd HCH I-Specific Discussions 0 08-01-2012 01:23 PM
2003 HCH Battery Light, IMA Light, and Check Egine Light SadCarTime HCH I-Specific Discussions 4 07-09-2012 09:05 AM


Tags
97, accord, blinking, check, civic, drive, engine, flashing, high, honda, hybrid, light, lite, mi, speed, tcm

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 03:35 AM.