New mwmber - GreenHybrid - Hybrid Cars

Introductions GreenHybrid welcomes you to the forum community. Please, tell us about yourself!

New mwmber

  #1  
Old 11-16-2015, 10:14 AM
Enthusiast
Thread Starter
Join Date: Nov 2015
Posts: 1
Default New mwmber

Good afternoon. I recently purchased a 2003 Honda Civic Hybrid for $1500.00. It has 153,000 miles.,
I live in Florida and it had a rebuilt title but was easy to register here. No problem with Insurance. I realize i was taking a chance with history unknown. So far no problems. All idiot lights work as they should when i key on, but no codes warnings etc when operating. I have put about 450 miles on it, live in a suburban setting so moderate traffic stops, about 150 miles of interstate driving. Currently show 52.3 mpg for the 450 miles, i'm thrilled with that. The battery charge level pretty well stays around 2/3 to 3/4 full, occasionally down to about half. When it gets down to half the charge indicater seems to come on regardless if i am braking or coasting until it rises up a bit, then normal.
CVT fluid was changed just prior to my purchase with Honda CVT fluid. CVT seems to operate as it should no shudder hesitation etc. Bought it knowing the Air conditioner compressor was shot. Will replace in the spring, for now i put a bypass belt on cutting the unit out. Is there a way of telling if this has the original IMA battery pack, all seems well. Should i purchase a grid charger
for periodic maintainance, and would it be wise to do another CVT fluid change just so i know my starting mileage with it. I have gotten alot of helpful info from this forum since i got it so thanks
 

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.