Abs light, codes. Bad hcu?? - GreenHybrid - Hybrid Cars

Abs light, codes. Bad hcu??

Reply

 
 
 
  #1  
Old 08-07-2018, 06:29 AM
Ridiculously Active Enthusiast
Thread Starter
Join Date: May 2007
Posts: 592
Default Abs light, codes. Bad hcu??

So yesterday I got abs & brake lights, Regen disabled and check brake system messages on the dash.
i drove it 5mi home, it was slower to stop than normal but stopped when I needed it to.

Getting codes c1478/1480

Think it's the hcu?
If so cheaper alternative to Ford?


Tone rings seem in tact, don't see any leaks, mastercylinder is full.
 
Reply With Quote
  #2  
Old 08-07-2018, 05:16 PM
Ridiculously Active Enthusiast
Thread Starter
Join Date: May 2007
Posts: 592
Default Re: Abs light, codes. Bad hcu??

$700 brake lines =(
 

Last edited by 08hybridok; 08-24-2018 at 07:26 PM.
Reply With Quote
  #3  
Old 08-08-2018, 08:25 AM
Active Enthusiast
Join Date: Jul 2007
Posts: 64
Default Re: Abs light, codes. Bad hcu??

Have you had any brake work done? I only started having HCU noise after I had my brake pads replaced. It's only been about a month, but after having the brake fluid flushed (a recommendation on a thread here), things have been fine.
 
Reply With Quote
  #4  
Old 08-08-2018, 11:41 AM
Ridiculously Active Enthusiast
Thread Starter
Join Date: May 2007
Posts: 592
Default Re: Abs light, codes. Bad hcu??

Originally Posted by tommyball View Post
Have you had any brake work done? I only started having HCU noise after I had my brake pads replaced. It's only been about a month, but after having the brake fluid flushed (a recommendation on a thread here), things have been fine.
I changed the rear pads many months ago.



Going to try the procedure on here for grounds (if I can find them) and the bleeding.
 

Last edited by 08hybridok; 08-24-2018 at 07:27 PM.
Reply With Quote
  #5  
Old 08-08-2018, 12:06 PM
Ridiculously Active Enthusiast
Join Date: Mar 2006
Location: Ventura, CA
Posts: 873
Default Re: Abs light, codes. Bad hcu??

Reply With Quote
  #6  
Old 08-08-2018, 01:21 PM
Ridiculously Active Enthusiast
Thread Starter
Join Date: May 2007
Posts: 592
Default Re: Abs light, codes. Bad hcu??

Originally Posted by econoline View Post
I've read so much in the last couple of days not sure.
I'm going to try the grounds first.

I was able to drive home from dealer with no issues or lights. Haven't tried driving it since.
Maybe the reset the abs module?

I'll need to read more on how to use forscan to clear it too.
 
Reply With Quote
  #7  
Old 08-08-2018, 06:17 PM
Enthusiast
Join Date: May 2015
Posts: 23
Default Re: Abs light, codes. Bad hcu??

Originally Posted by 08hybridok View Post
I've read so much in the last couple of days not sure.
I'm going to try the grounds first.

I was able to drive home from dealer with no issues or lights. Haven't tried driving it since.
Maybe the reset the abs module?

I'll need to read more on how to use forscan to clear it too.

Any luck? I am trying to figure out what I should so still. How were you able to reach all the grounds?? How did you clean them?
 
Reply With Quote
  #8  
Old 08-08-2018, 07:16 PM
Ridiculously Active Enthusiast
Thread Starter
Join Date: May 2007
Posts: 592
Default Re: Abs light, codes. Bad hcu??

Originally Posted by egon10psi View Post
Any luck? I am trying to figure out what I should so still. How were you able to reach all the grounds?? How did you clean them?
IDK yet; just found 4 grounds, removed; sandpapered, sprayed contact cleaner on. cleaned batt terminals (didn't look bad at all).

The grounds I found: under the 12v batt easy to pull bat & reach it between tray & air filter) one on the firewall in front of steering wheel; 2 by washerfluid, 1 on top easy peasy, 1 at bottom of filler neck, not so easy peasy =(

haven't tried test run yet. started up, presed brake pedal, put in R & D, back into park. no lights yet (but I was also able to drive 10ish miles home from dealer w/no lights either.

next step is the confusing line flushing procedure. not sure I'm up for that; or quite understand the exact procedure yet.
 
Reply With Quote
  #9  
Old 08-08-2018, 07:30 PM
LonnieU's Avatar
Enthusiast
Join Date: Sep 2017
Location: Mt. Airy, NC
Posts: 10
Default Re: Abs light, codes. Bad hcu??

Read this thread https://www.greenhybrid.com/forums/f...es-help-31530/ ,especially the last page.

Diagrams show the grounds that have been identified by Ford in a Technical Bulletin as known culprits. These are the ground leads for the HCU itself. Your best friend is someone with a lift as they pretty much have to be done from underneath, less removing the entire HCU itself.

Good Luck!
 
Reply With Quote
  #10  
Old 08-13-2018, 05:21 AM
Enthusiast
Join Date: May 2015
Posts: 23
Default Re: Abs light, codes. Bad hcu??

Originally Posted by 08hybridok View Post
IDK yet; just found 4 grounds, removed; sandpapered, sprayed contact cleaner on. cleaned batt terminals (didn't look bad at all).

The grounds I found: under the 12v batt easy to pull bat & reach it between tray & air filter) one on the firewall in front of steering wheel; 2 by washerfluid, 1 on top easy peasy, 1 at bottom of filler neck, not so easy peasy =(

haven't tried test run yet. started up, presed brake pedal, put in R & D, back into park. no lights yet (but I was also able to drive 10ish miles home from dealer w/no lights either.

next step is the confusing line flushing procedure. not sure I'm up for that; or quite understand the exact procedure yet.

Any update?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Abs light, codes. Bad hcu??


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.