Noise, Anti-Freeze, Engine not shutting off - GreenHybrid - Hybrid Cars


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-19-2017, 08:07 AM
Enthusiast
Thread Starter
 
Join Date: Aug 2014
Posts: 3
Default Noise, Anti-Freeze, Engine not shutting off

This morning at a light I noticed my engine didn't sound right, loud, water pump bearing?? I don't know.


I smelled a faint whiff of anti-freeze (was that my car?)


I noticed the engine wasn't shutting off, it should have. While still at the light I put it into Neutral and the engine shut off. I put it back into Drive and it started. I did it a couple of times.


I stopped and checked the anti-freeze level, it was slightly below the cold level. I would have thought that it should be above the cold level.


Anyway, if it were the water pump, would/could it cause the ICE not to shut off?


Thanks in advance for your thoughts.


Paul
Reply With Quote
  #2  
Old 04-19-2017, 12:11 PM
Enthusiast
Thread Starter
 
Join Date: Aug 2014
Posts: 3
Default More info - getting weird!

I'm at work, 30 miles from home. At lunch I drove the car. Very little power, Stepped on the accelerator pedal all the way and it just crawled, but finally worked it's way up to speed. Gradually, it got better. Today is a hot day here, probably 80. After lunch, I drove back to work, and it had normal power. The ICE didn't shut off once on the way to or back from lunch.


Anybody care to guess???


This seems to be a weird one.
Reply With Quote
  #3  
Old 04-20-2017, 05:01 AM
Enthusiast
 
Join Date: Aug 2016
Posts: 31
Default Re: Noise, Anti-Freeze, Engine not shutting off

Not a clue here. I think you need to run FORscan on it
Reply With Quote
 
 
Reply

Related Topics
Thread Topic Starter Forum Replies Last Post
Battery Keeps Running When Shutting Off Engine KonaGuy Honda Civic Hybrid 5 08-03-2011 11:45 PM
Shutting off ignition question gpb5200 Fuel Economy & Emissions 8 05-31-2009 01:46 AM
ICE shutting off without ECON button on grinch1134 Ford Escape Hybrid 3 04-11-2008 06:22 PM
shutting off at idle Jerry&Natalie Ford Escape Hybrid 73 04-02-2007 11:19 PM
shutting hybrid off during auto-stop cawfebug HCH II-Specific Discussions 10 12-20-2006 07:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 07:50 PM.