Wrench Icon and "Service Soon" Message

  #1  
Old 07-17-2008, 08:39 PM
Active Enthusiast
Thread Starter
Join Date: Jun 2008
Posts: 81
Default Wrench Icon and "Service Soon" Message

I bought a previously owned 2005 FEH 4WD with 59,997-miles. I had no issues the first few weeks, but, within the past week, the wrench icon and "service soon" message have appeared. The wrench icon has stayed until the vehicle was turned off and restarted. From what I've read, the dealer (or any other service center) has no luck diagnosing the problem unless the wrench icon is displayed. Is that correct? I have read a recommendation of taking the vehicle to Auto Zone while the wrench icon is displayed, so they can hook it up to a ScanGauge for free. Is that the best recommendation? Luckily, I have an Auto Zone a few miles away, but both times the problem occurred was when my wife or I could not take it to Auto Zone. Maybe it will happen during the day this week when we are near Auto Zone to get it checked out. It seems there are many different reasons this could be happening. Thanks!
 

Last edited by Escape_from_Hanover; 07-17-2008 at 09:07 PM.
  #2  
Old 07-19-2008, 11:20 AM
Ridiculously Active Enthusiast
Join Date: Mar 2006
Posts: 1,401
Default Re: Wrench Icon and "Service Soon" Message

Originally Posted by Escape_from_Hanover View Post
I bought a previously owned 2005 FEH 4WD with 59,997-miles. I had no issues the first few weeks, but, within the past week, the wrench icon and "service soon" message have appeared. The wrench icon has stayed until the vehicle was turned off and restarted. From what I've read, the dealer (or any other service center) has no luck diagnosing the problem unless the wrench icon is displayed. Is that correct? I have read a recommendation of taking the vehicle to Auto Zone while the wrench icon is displayed, so they can hook it up to a ScanGauge for free. Is that the best recommendation? Luckily, I have an Auto Zone a few miles away, but both times the problem occurred was when my wife or I could not take it to Auto Zone. Maybe it will happen during the day this week when we are near Auto Zone to get it checked out. It seems there are many different reasons this could be happening. Thanks!

Here is a good possibility... at least its what happened to me. Look around here for a different message from me... don't have time to find it for you... You PROBABLY have to take the car into FORD with the light ON... and you can't restart the engine, leave it on or it might clear the code. Ford will hook up the standard equipement, find nothing but since the light is on they'll actually believe you and then go get out the more "advanced" code reader... it will probably flag that your A/C mixing door motor for the battery is failing. It doens't flag a standard code that can be read with the standard reader... its considered a climate control code and they clear themselves... clearly since its cooling your battery it SHOULD be a drivetrain code, but someone at Ford didn't think so.
 
  #3  
Old 07-19-2008, 01:46 PM
Ridiculously Active Enthusiast
Join Date: Nov 2006
Location: Southwestern Pa
Posts: 1,747
Default Re: Wrench Icon and "Service Soon" Message

Did your vehicle get the hybrid battery harness battery connector replaced last fall (2007)? There was a recall for just this item and if my memory serves me correctly, there were a few posters that had the "wrench Icon and service soon" message go away after this recall service work was completed? Go to this link: http://www.ford.com/owner-services/m...ll-information
to find out whether the service work was completed.
 
  #4  
Old 07-23-2008, 12:36 PM
Active Enthusiast
Join Date: Jul 2006
Location: Overland Park, Kansas
Posts: 95
Default Re: Wrench Icon and "Service Soon" Message

Had the wrench light come again, about 5 times so far, took it to the dealer today for an oil change due to the fact that I got a message saying 10% oil life left - change it ..... Learned two things: with only 6000 miles on the car and a year old - the oil life indicator is on a timer- the car is one year old and thats the reason it came on - I was hoping that magically the car was smart enought to test the oil - silly me. and two the wernch light was coming on because the battery fan quit and was causing an battery overheating condition.. Of course, dealer must order the fan - ready tomorrow maybe
 
  #5  
Old 07-23-2008, 01:26 PM
rmcmast's Avatar
Active Enthusiast
Join Date: Jan 2007
Location: Kansas City, MO
Posts: 102
Default Re: Wrench Icon and "Service Soon" Message

Originally Posted by KC Rusty View Post
Learned two things: with only 6000 miles on the car and a year old - the oil life indicator is on a timer- the car is one year old and thats the reason it came on
I think it's 10,000 miles or 1 year since the oil change, whichever comes first.

-- Rick
 
  #6  
Old 07-23-2008, 06:29 PM
Active Enthusiast
Thread Starter
Join Date: Jun 2008
Posts: 81
Default Re: Wrench Icon and "Service Soon" Message

Here is a good possibility... at least its what happened to me. Look around here for a different message from me... don't have time to find it for you... You PROBABLY have to take the car into FORD with the light ON... and you can't restart the engine, leave it on or it might clear the code. Ford will hook up the standard equipement, find nothing but since the light is on they'll actually believe you and then go get out the more "advanced" code reader... it will probably flag that your A/C mixing door motor for the battery is failing. It doens't flag a standard code that can be read with the standard reader... its considered a climate control code and they clear themselves... clearly since its cooling your battery it SHOULD be a drivetrain code, but someone at Ford didn't think so.
The light came on yesterday, and I happened to be off of work, so I took it to AutoZone to see if they could provide me with the code while the wrench light and "Service Soon" message were on, but the gentleman told me it can only get codes for "Check Engine" message. I took it several miles to a local Ford dealer, and the service advisor said they could not look at it that day, and they would be able to use their computer to get the code, because it is stored.

Did your vehicle get the hybrid battery harness battery connector replaced last fall (2007)? There was a recall for just this item and if my memory serves me correctly, there were a few posters that had the "wrench Icon and service soon" message go away after this recall service work was completed? Go to this link: http://www.ford.com/owner-services/m...ll-information
to find out whether the service work was completed.
I went to Ford's website, entered my VIN, and it said there were no recalls for my FEH.

Had the wrench light come again, about 5 times so far, took it to the dealer today for an oil change due to the fact that I got a message saying 10% oil life left - change it ..... Learned two things: with only 6000 miles on the car and a year old - the oil life indicator is on a timer- the car is one year old and thats the reason it came on - I was hoping that magically the car was smart enought to test the oil - silly me. and two the wernch light was coming on because the battery fan quit and was causing an battery overheating condition.. Of course, dealer must order the fan - ready tomorrow maybe
Do you hear your battery fan turn on and off? I never have. Of course, with three kids in the backseat, it is hard to hear much of anything other than them.

Can the battery overheating cause "poor" FE? I am averaging 28.5-MPG after 4 fill-ups, which is within the new EPA estimates of 29-MPG city/27-MPG highway for my 2005 FEH 4WD, I feel it should be getting better than that.

Everytime I have noticed the wrench light and "Service Soon" message come on, it was right after the FEH went into EV mode.

Thanks everyone!
 

Last edited by Escape_from_Hanover; 07-23-2008 at 06:32 PM.
  #7  
Old 07-23-2008, 09:03 PM
Ridiculously Active Enthusiast
Join Date: Mar 2006
Posts: 1,401
Default Re: Wrench Icon and "Service Soon" Message

Originally Posted by Escape_from_Hanover View Post
The light came on yesterday, and I happened to be off of work, so I took it to AutoZone to see if they could provide me with the code while the wrench light and "Service Soon" message were on, but the gentleman told me it can only get codes for "Check Engine" message. I took it several miles to a local Ford dealer, and the service advisor said they could not look at it that day, and they would be able to use their computer to get the code, because it is stored.
If its the same problem I had...He's wrong... that code is NOT STORED! Its a climate control code and clears when the light clears. It wasn't considered "important" enough to store apparently. My Ford dealer couldn't read the code after the next restart when the light went off.... but they read it when I drove it there the next time it came on because I never shut the darn thing off.. they plugged in an advanced reader with the light on and boom.... they had the code.
 
  #8  
Old 07-25-2008, 05:27 PM
Active Enthusiast
Join Date: Apr 2008
Location: St. Louis, MO
Posts: 79
Default Re: Wrench Icon and "Service Soon" Message

No wrench light here.. yet.. but I've noticed the FE has dropped a bit on my '05 FEH 4WD (Was 31-32 now 27-28). I had pretty much choked it up to a lot of A/C usage and short trips, but my wife was complaining that the A/C wasn't quite as cold as she thought it should be (It's been quite hot out the last couple of weeks).

So I took it to work and checked it out and found it was almost a pound low on Refrigerant... I evacuated and recharged the system and added some dye.. Hopefully there are no leaks but we'll see... anyways it's now blowing ice cold.

And FE has increased 2-3MPG since I've done this. I'm wondering if it was limiting battery usage due to higher temperatures because of the not-so-cold A/C?
 
  #9  
Old 07-25-2008, 08:12 PM
Ridiculously Active Enthusiast
Join Date: Nov 2006
Location: Southwestern Pa
Posts: 1,747
Default Re: Wrench Icon and "Service Soon" Message

Originally Posted by Scahpe View Post
No wrench light here.. yet.. but I've noticed the FE has dropped a bit on my '05 FEH 4WD (Was 31-32 now 27-28). I had pretty much choked it up to a lot of A/C usage and short trips, but my wife was complaining that the A/C wasn't quite as cold as she thought it should be (It's been quite hot out the last couple of weeks).

So I took it to work and checked it out and found it was almost a pound low on Refrigerant... I evacuated and recharged the system and added some dye.. Hopefully there are no leaks but we'll see... anyways it's now blowing ice cold.

And FE has increased 2-3MPG since I've done this. I'm wondering if it was limiting battery usage due to higher temperatures because of the not-so-cold A/C?
Yes. Too hot or too cold hinders hybrid battery performance.
 
  #10  
Old 07-28-2008, 12:06 AM
Ridiculously Active Enthusiast
Join Date: May 2007
Posts: 592
Default Re: Wrench Icon and "Service Soon" Message

Well I've been avoinding reading this message since I didn't want to cause the wrench to come on; but it did anyway ;( Once on Sat am, went off after restart, nothing on sun (3 out of 4 trips) then on again sun late nite. Book says Throttole contol/powertrain, see dealer asap. No message on center console. SG says no codes found.
So it sounds like I need the light to come on, and not turn the car off & drive to a dealer so they can read the code.

It has been 100+ here lately, can't say I hear the battery fan/door, but never rally could anyway.
 

Thread Tools
Search this Thread
Quick Reply: Wrench Icon and "Service Soon" Message


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.