HCH I-Specific Discussions Model Years 20032005

2004 civic hybrid... engine is missing bad on hill climbs

  #1  
Old 02-16-2019, 07:31 AM
Enthusiast
Thread Starter
Join Date: Jan 2019
Posts: 12
Default 2004 civic hybrid... engine is missing bad on hill climbs

The car is a manual trans with 380k. I bought it with 340k and recently replaced the plugs and coils because the car was missing bad on the road. Ran steady after that. Then I got some remanufactured injectors and replaced those and it's been a headache. First, the wrong ones arrived and were missing, then the right ones came in and they're missing now too, or causing a miss whenever I'm accelerating up hills. Otherwise, the car runs stronger and accelerates with power that it wasn't really showing before.

so my thoughts are that maybe I messed up the wiring harness on the coils and injectors when I had to keep changing everything out maybe. The clip plastic was old and a few were snapping off, but the connections were still snug. This or maybe the injectors are putting too much fuel into the cylinder.

the orings weren't leaking any gas. I didn't put the clips back onto the injectors when tightening back down the fuel rail for the third time. There was a major leak with the first batch of incorrect injectors, but that was remedied by better orings and making sure they seated properly when tightening down the rail.

could their be a vacuum leak?

my other observations are that when the car is missing, the fuel economy gauge goes from over forty to just over 20 mpg. Then if I let off the gas and then restomp, it seems to function fine for a second. Nothing else is going on during the misfire as far as the ima is concerned. It's not charging or discharging during the misfire.

the remans came from an eBay seller. Bought them for 90 bucks.

please help. This is beyond frustrating. Thanks.
 

Last edited by Thesupersoap33; 02-16-2019 at 07:36 AM. Reason: .
  #2  
Old 02-16-2019, 10:53 AM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,028
Default Re: 2004 civic hybrid... engine is missing bad on hill climbs

plugs and coils fix car
remanufactured injectors broke car

Re-install old injectors?

What codes are you getting?

Vacuum leak would likely manifest at idle and cause other problems.
 
Related Topics
Thread
Topic Starter
Forum
Replies
Last Post
Phototone
HCH I-Specific Discussions
5
06-12-2015 06:06 PM
GreenHybrid Editor
Journalism & The Media
0
02-08-2014 05:50 AM
Zoom On
Ford Escape Hybrid
10
12-28-2007 06:04 AM
drquine
Fuel Economy & Emissions
5
09-21-2005 05:43 PM


Thread Tools
Search this Thread
Quick Reply: 2004 civic hybrid... engine is missing bad on hill climbs


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.