Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

  #1  
Old 06-28-2019, 08:22 AM
Enthusiast
Thread Starter
Join Date: Feb 2019
Posts: 5
Default Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

Hello to all,

I have Altima Hybrid 2011 which performs fine expect weird problem happening only at higher speeds, usually anywhere over 50 MPH.
Engine shuts off, I get check engine, VDC, hybrid system kicks in and I have to immediately drive into shoulder lane to turn it OFF and then then back ON in order to drive way.
This problem never happens in the city driving conditions. Codes would disappear after day or two unless I go onto highway again.

These are the codes:
p0a94
p0ac4

P.S. I inspected battery, all cells ~7.4v, cleaned contacts. Fan works. I'm pretty sure it's not related to the battery.
 
  #2  
Old 06-28-2019, 02:26 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,042
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

What aren't you telling us?
 
  #3  
Old 06-29-2019, 12:47 PM
Enthusiast
Thread Starter
Join Date: Feb 2019
Posts: 5
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

Is there something else suppose to be? I guess I don't know where to look. Let me know.
Transmission shifts fine and smooth, engine runs no problem. idk
 

Last edited by CTguy; 06-29-2019 at 12:49 PM.
  #4  
Old 06-29-2019, 03:25 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,042
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

You're making us look through a key hole at this problem. What is your history with the car? Did you just get it? At auction? Has it been trouble free for you for 100K miles? Was it recently crashed and restored? Are you trying to flip it?

Is it the original battery? Why did you muck with the battery when you weren't getting battery related codes?

Your car has a CVT. It never "shifts fine and smooth". It never shifts at all. Ever.

P0A94 is a DC-DC converter performance issue.
P0AC4 is a faulty Hybrid Powertrain Control Module.

Did you get these codes before or after you mucked with the battery?
 
  #5  
Old 07-15-2019, 02:25 PM
Enthusiast
Thread Starter
Join Date: Feb 2019
Posts: 5
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

hey Steve,
the problem was already there when I bought it on 160k, it was popping up not too often on speeds above 55 after 10-20 miles. recently it started showing up more often.
now 1-3 miles on the highway would be enough.
no car accidents as i know. scratches from parking, no more than that.

yes, i'm preparing the car for sale. fixed everything just want to figure out what is going on with that problem. some people are saying it could be transmission, others powertrain controle module.
i just wanted a second opinion so i could fix it and sell. moving down south and this car will be a burden sitting at my parents yard (pulling another car already and no opportunity to bring this one with me).
just want to avoid "replace the part" as diagnostics but in the same time be fair to whoever will buy it. labor mechanic work is not a problem for me. just sometimes hard to pin point what it could be.


Originally Posted by S Keith View Post
Did you get these codes before or after you mucked with the battery?
before.
 

Last edited by CTguy; 07-15-2019 at 02:37 PM.
  #6  
Old 07-15-2019, 02:36 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,042
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

To avoid the "replace the part" trap, you likely need to get a subscription to Nissan's tech data:

https://www.nissan-techinfo.com/deptsubs.aspx

$20 for one day, $75 for a month.

You will get complete access to the service manuals that have the full diagnostic steps. You may also have incomplete info (missing codes) as standard code readers fail to read a lot of hybrid codes. You'll need the Nissan Consult III or something higher end by Bosch, Snap-on or other "pro" option.
 
  #7  
Old 07-15-2019, 04:14 PM
Enthusiast
Thread Starter
Join Date: Feb 2019
Posts: 5
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

Originally Posted by S Keith View Post
To avoid the "replace the part" trap, you likely need to get a subscription to Nissan's tech data:

https://www.nissan-techinfo.com/deptsubs.aspx

$20 for one day, $75 for a month.

You will get complete access to the service manuals that have the full diagnostic steps. You may also have incomplete info (missing codes) as standard code readers fail to read a lot of hybrid codes. You'll need the Nissan Consult III or something higher end by Bosch, Snap-on or other "pro" option.
Autozone check probably use the cheap non-informative ones right
 
  #8  
Old 07-15-2019, 04:18 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,042
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

Without a doubt. I've had many instances where Autozone fails to read a code that is present and can be read by a cheap bluetooth OBDII reader.

O'Reilly uses Bosch readers, so I always choose them. They are the only parts store that have read codes that I KNOW will not pull up on a "consumer" grade reader.

A diagnostic at the dealership for $120-150 + $75 in service manuals may help you save a lot of money OR help you determine that this car is destined for the junk yard....
 
  #9  
Old 07-15-2019, 04:52 PM
Enthusiast
Thread Starter
Join Date: Feb 2019
Posts: 5
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

Originally Posted by S Keith View Post
Without a doubt. I've had many instances where Autozone fails to read a code that is present and can be read by a cheap bluetooth OBDII reader.

O'Reilly uses Bosch readers, so I always choose them. They are the only parts store that have read codes that I KNOW will not pull up on a "consumer" grade reader.

A diagnostic at the dealership for $120-150 + $75 in service manuals may help you save a lot of money OR help you determine that this car is destined for the junk yard....

I guess I will start from O'Reilly to see if they will pull any sub-codes and then will see what is going on.
 
  #10  
Old 07-15-2019, 06:17 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 3,042
Default Re: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4

They can't pull subcodes or "detail" codes, but they can read codes consumer readers can't.
 
Related Topics
Thread
Topic Starter
Forum
Replies
Last Post
vasili
Toyota Camry Hybrid
13
10-22-2018 07:14 AM
vasili
Toyota Motor Corporation
0
09-16-2015 06:11 PM
mrazndead
Nissan Altima Hybrid/Infiniti M35h/ Q50 hybrid
3
01-15-2015 04:28 PM
hamm3r
Toyota Camry Hybrid
10
06-20-2007 05:47 AM
these_go211
Honda Civic Hybrid
5
04-19-2005 06:17 PM


Thread Tools
Search this Thread
Quick Reply: Engine shuts off on highspeed to EV Mode - p0a94 p0ac4


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.