NAH troubles at high speeds

  #1  
Old 02-28-2015, 10:37 AM
Enthusiast
Thread Starter
Join Date: Feb 2015
Posts: 1
Default NAH troubles at high speeds

Hello to all,

As the title says I have NAH which performs fine expect weird problem happening only at higher speeds, usually anywhere over 55 mph. Engine shuts off, I get both check engine and hybrids lights on, hybrid system kicks in and I have to immediately drive into shoulder lane to turn it OFF and then then back ON in order to drive way. This problem never happens in the city driving conditions. Codes would disappear after day or two unless I go onto highway again... I went to local dealership, they forced me to repair both catalytic, however problem is still there.

These are the codes:

P0A94 Converter
P0A65 over-voltage
P0AC4 MIL on request

Any help is appreciated, thanks.
 
  #2  
Old 03-01-2015, 12:39 PM
Active Enthusiast
Join Date: Jun 2007
Posts: 74
Default Re: NAH troubles at high speeds

That happened to me once when I ran out of gas. Maybe the there is sensor related to fuel flow that is failing and telling the computer that the car is out of gas.

Just an idea.

Good luck.
 
Related Topics
Thread
Topic Starter
Forum
Replies
Last Post
phenderson
Toyota Camry Hybrid
19
01-19-2009 10:13 AM
bkushner
Toyota Camry Hybrid
13
01-13-2009 06:01 PM
JoeFuture
HCH II-Specific Discussions
20
07-12-2008 06:51 PM
GTBaker
Website Questions & Input
4
05-02-2007 05:05 PM
usernamenumber
Toyota Prius
16
09-25-2005 10:04 PM


Thread Tools
Search this Thread
Quick Reply: NAH troubles at high speeds


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.