GreenHybrid - Hybrid Cars

GreenHybrid - Hybrid Cars (/forums/)
-   GM Hybrid Trucks, Cadillac Escalade Hybrid, Chevrolet Tahoe Hybrid & GMC Yukon Hybrid (https://www.greenhybrid.com/forums/f69/)
-   -   09 Yukon Hybrid Service Hybrid Systems (https://www.greenhybrid.com/forums/f69/09-yukon-hybrid-service-hybrid-systems-30981/)

Green1y1z 10-10-2016 09:48 AM

09 Yukon Hybrid Service Hybrid Systems
 
Hi All! I've searched this group a lot since purchasing my '09 Yukon Hybrid 3 years ago and am now posting for the first time for some assistance. I have 108,000 miles & live in FL, if that matters. 2 weeks ago the Service Hybrid Systems alert appeared on the dash when starting the vehicle & it would go away. Now is stays on the entire time I'm driving. My mechanic, who owned a Hyhoe, did the diagnostics for me & found that the Hybrid battery would not go past 52% SOC & needed to be replaced. I contacted GM to see about replacement under warranty & was told that I had to have the vehicle diagnosed at a GM Dealership. My Yukon is at the GM Dealership today and am being told that the battery is not the issue and that the SDGM Module is the issue. I guess my question is could it be the SDGM module? Appreciate any help!

Hillbilly_Hybrid 10-14-2016 10:49 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 
How high in SOC did the mechanic say it should go? It should never go over 70%


Normal is roughly between 45 and 65

Green1y1z 10-31-2016 10:04 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 
Thanks for the reply! He didn't say but the SOC didn't go over 52% during the first diagnostic & not over 47% during the second diagnostic. Which according to your post is within normal. During the second diagnostic we did witness issues with low voltage, which he attributed to the hybrid battery not maintaining the proper charge. The code for a bad SDGM module comes back immediately once reset. Could the code for the bad SDGM module signal the vehicle to display "Service Hybrid Systems"? I can't figure that out as they do not seem to be linked but I admit that I am not an expert.

For now I've just been driving my Yukon with the warning trying to decide on how to proceed. Leaning towards trading it in if the battery needs to be replaced BUT it's killing me to think about that. I love this vehicle!

Sean Iamtheplug Belle 11-03-2016 11:55 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 
i just replaced my battery yesterday cost me 3000 with install it was better than getting a newer car and more payments bcs i loved mines also 2009 escalade , now it runs like a charm and gas mileage is back up

Green1y1z 09-30-2017 07:39 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 
Update.... I ended up replacing the SDGM module Nov. 2016 and the Service Hybrid System light never came back. :D GM dealership says my battery is still good.

Sal Calabrese 01-24-2018 11:53 PM

Re: 09 Yukon Hybrid Service Hybrid Systems
 

Originally Posted by Green1y1z (Post 263839)
Update.... I ended up replacing the SDGM module Nov. 2016 and the Service Hybrid System light never came back. :D GM dealership says my battery is still good.

How much did the dealer charge you to replace the SDGM module? My Tahoe is doing the same exact thing.

Green1y1z 01-25-2018 10:24 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 

Originally Posted by Sal Calabrese (Post 264681)
How much did the dealer charge you to replace the SDGM module? My Tahoe is doing the same exact thing.

I paid $503 after a coupon. Original total was $534.

dnt1010 11-18-2018 05:41 PM

Re: 09 Yukon Hybrid Service Hybrid Systems
 
Missed Diagnosis seems to be a common thing with any vehicle issue whether it is Hybrid or Not. Sad part is that most likely your issue was probably just a bit of corrosion in the SDGM plug connection and not the module itself. You could have fixed this yourself in less than 5 minutes with about 5 bucks worth of contact cleaner and dielectric grease.............. Reminds me of when I had bought a Brand New Ford 4x4 truck. The cruise control stopped working so i stopped by the dealership and they diagnosed the Trans control module they got one on order and would call when it came in. Well when I got home I thought that I might just sneak a peek under the truck to see what it looked like. The wire bundle going to the transmission had been chewed on by my new puppy dog and one wire was completely in two! I reconnected the broken wire, taped it all up and everything worked just fine and I never did go back to that goofy dealership service department. Hard to get good help nowadays Haha.

Luisj 02-19-2019 11:55 AM

Re: 09 Yukon Hybrid Service Hybrid Systems
 

Originally Posted by Green1y1z (Post 263839)
Update.... I ended up replacing the SDGM module Nov. 2016 and the Service Hybrid System light never came back. :D GM dealership says my battery is still good.

hello where exactly is the sdgm module i am trying to search it online but i have no luck
my 2009 tahoe hybrid did not start this morning my battery is good i even bought a new 1 to see if it was the battery but nothing happens the only thing on is the
service your hybrid system
idk what else to do any ideas thanks


All times are GMT -7. The time now is 08:19 AM.


© 2019 MH Sub I, LLC dba Internet Brands