Service hybrid system message with no CEL

  #11  
Old 07-23-2018, 08:55 PM
Enthusiast
Join Date: Jul 2018
Posts: 10
Default Re: Service hybrid system message with no CEL

That's interesting!
 
  #12  
Old 07-30-2018, 08:12 AM
Enthusiast
Thread Starter
Join Date: Oct 2015
Location: Northern Va
Posts: 28
Default Re: Service hybrid system message with no CEL

Ok so dealer called, it’s one of the control modules. It needs the new module then has to be programmed to the truck, I should have it back tomorrow evening or Wednesday at the latest. I will post up exactly what the service ticket says, really glad it’s not the battery.
 
  #13  
Old 07-30-2018, 09:35 AM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 2,925
Default Re: Service hybrid system message with no CEL

Be prepared for a misdiagnoses. Attempt to secure a commitment from the dealership that you don't have to pay for work that you don't need or for their inability to diagnose issues with their product.

Good luck!
 
  #14  
Old 07-30-2018, 11:05 AM
Enthusiast
Thread Starter
Join Date: Oct 2015
Location: Northern Va
Posts: 28
Default Re: Service hybrid system message with no CEL

Ok, is this from personal experience? Is this common with these vehicles? I hope this isn’t the case. Guess we will see. Thanks for the vote of confidence, lol.
 
  #15  
Old 07-30-2018, 11:06 AM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 2,925
Default Re: Service hybrid system message with no CEL

Not certain of the larger picture, but there are multiple instances on this site alone.
 
  #16  
Old 07-30-2018, 11:10 AM
Enthusiast
Thread Starter
Join Date: Oct 2015
Location: Northern Va
Posts: 28
Default Re: Service hybrid system message with no CEL

Ok well I have to start somewhere. I have to give the dealer a chance. If it goes down that road they can keep the darn thing, if it’s that complicated (which it shouldn’t be) I’ll jump ship. I’m not willing to spend a bunch of money to guess on anything.
 
  #17  
Old 07-31-2018, 03:29 PM
Enthusiast
Thread Starter
Join Date: Oct 2015
Location: Northern Va
Posts: 28
Default Re: Service hybrid system message with no CEL

Ok so the invoice says internal failure in serial data gateway module causing b1000-39 DTC.
Serial data gateway module replaced.

I cant seem to find a b1000-39 DTC. Drove the car this afternoon, it’s holding in auto stop mode longer again and accelerates a bit longer in electric mode. Not a large sample size, but fingers crossed.
 
  #18  
Old 07-31-2018, 07:21 PM
Ridiculously Active Enthusiast
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 2,925
Default Re: Service hybrid system message with no CEL

So far so good it seems.
 
  #19  
Old 11-01-2018, 05:09 PM
Enthusiast
Join Date: Apr 2011
Location: Denver CO
Posts: 11
Default Re: Service hybrid system message with no CEL

Can you advise of the cost of the replacement of this SDGM Module? I believe this may be the problem with my 2010 Caddy Escalade Hybrid.

Thanks!
 
  #20  
Old 11-02-2018, 01:38 AM
Enthusiast
Thread Starter
Join Date: Oct 2015
Location: Northern Va
Posts: 28
Default Re: Service hybrid system message with no CEL

I had some other stuff done while it was in, IIRC $500-700 range.
 

Thread Tools
Search this Thread
Quick Reply: Service hybrid system message with no CEL


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.