Service hybrid system message with no CEL

  #31  
Old 12-26-2018, 04:13 AM
Enthusiast
Join Date: Dec 2018
Posts: 6
Default Re: Service hybrid system message with no CEL

Originally Posted by Ivan Popko View Post
it's under dash
Can u upload a picture of it please? I couldn't find a picture or a location of it.
 
  #32  
Old 12-26-2018, 06:01 AM
Enthusiast
Join Date: Dec 2018
Posts: 7
Default Re: Service hybrid system message with no CEL

Originally Posted by Stephen Hodges View Post
Can u upload a picture of it please? I couldn't find a picture or a location of it.
Did you found a new module itself? Do you have someone who can program it? Where are you located?

And looks like they asking to remove whole dash to take that upper trim piece out.



 
  #33  
Old 12-26-2018, 02:20 PM
Enthusiast
Join Date: Dec 2018
Posts: 6
Default Re: Service hybrid system message with no CEL

Originally Posted by Ivan Popko View Post
Did you found a new module itself? Do you have someone who can program it? Where are you located?

And looks like they asking to remove whole dash to take that upper trim piece out.


I just needed to see were the module was so I could check the volts at it like you said. I'm located in Owensboro ky. I've not yet had a chance to work on the truck. I wonder if the reset procedure the other guy posted would work?
 
  #34  
Old 12-26-2018, 02:23 PM
Enthusiast
Join Date: Dec 2018
Posts: 7
Default Re: Service hybrid system message with no CEL

Originally Posted by Stephen Hodges View Post
I just needed to see were the module was so I could check the volts at it like you said. I'm located in Owensboro ky. I've not yet had a chance to work on the truck. I wonder if the reset procedure the other guy posted would work?

I wasn't able to find one of those modules new, so I got one from wreck yard. Will replace it tommorow I'll keep you posted.
 
  #35  
Old 02-16-2019, 05:34 PM
Enthusiast
Join Date: Feb 2019
Posts: 3
Default Re: Service hybrid system message with no CEL

I just used green bean battery ,for a new hybrid battery in my chevy Tahoe. $2940. dealer wanted $5000

they came to my house and changed it. I have 5 year unlimited mile warranty on new battery
 
  #36  
Old 02-26-2019, 03:29 PM
Enthusiast
Join Date: Feb 2019
Posts: 3
Default Re: Service hybrid system message with no CEL

Sorry to bother but what is the CEL ...and how do u post something on here for help im new to this
my tahoe 2009 hybrid just popped up with the
service hybrid system after working fine the day before
i tried buying a new battery and that wasnt the issue mine was just fine
Also all the lights inside turn on just fine but wont crank over or anything
 
Related Topics
Thread
Topic Starter
Forum
Replies
Last Post
EOppie
Ford Escape Hybrid
16
04-23-2019 06:21 AM
nikkrae101
General Motors Corporation
8
04-20-2019 10:04 PM
ekimne
GM Hybrid Trucks, Cadillac Escalade Hybrid, Chevrolet Tahoe Hybrid & GMC Yukon Hybrid
2
12-27-2018 05:46 PM
scott30211
GM Hybrid Trucks, Cadillac Escalade Hybrid, Chevrolet Tahoe Hybrid & GMC Yukon Hybrid
3
01-16-2016 08:39 PM
newgreenie
Ford Escape Hybrid
18
11-28-2006 08:18 AM


Thread Tools
Search this Thread
Quick Reply: Service hybrid system message with no CEL


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.