Tahoe CEL Won't Illuminate - GreenHybrid - Hybrid Cars


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-12-2017, 11:42 AM
Enthusiast
Thread Starter
 
Join Date: Aug 2017
Posts: 3
Default Tahoe CEL Won't Illuminate

08 tahoe hybrid. The check engine light does not illuminate at start-up, when there is an mil present, or any other time. I also have the associated pid for malfunction indicator circuit failure. I don't see any blown fuses. Also, I think all the 12v acc plugs work (2 in front, 1 inside center console, 1 behind center console by the rear hvac / radio controls).

does anyone know exactly what fuse protects the check engine light? Has anyone ever had this happen? Anyone know the most common cause other than a fuse or the led itself? And does anyone have the circuit diagram?


thanks all
Reply With Quote
  #2  
Old 08-14-2017, 09:46 AM
Active Enthusiast

 
Join Date: May 2010
Location: Paradise Valley Arizona
Posts: 98
Default Re: Tahoe CEL Won't Illuminate

Does your Onstar work, on the rear view mirror? or the ambient temperature gauge on the dash? Believe it or not the CEL is somehow connected to these. There is a fuse under the hood that is not even close to being marked correctly that is connected to these.
My rear view mirror plug had a short and I had these symptoms. Unfortunately neither the fuse guide in my owners manual nor the under hood fuse map is even remotely close to reality for my Hybrid, I guess they didn't bother to change it from the regular Tahoe.(at least on mine) I literally had to pull every fuse to find the right one and nothing was marked any way that would make any sense. I don't recall which fuse it is, but it is under the hood.
Reply With Quote
  #3  
Old 08-14-2017, 02:18 PM
Enthusiast
Thread Starter
 
Join Date: Aug 2017
Posts: 3
Default Re: Tahoe CEL Won't Illuminate

Yes, the On-star works (though I never used it, but I did press the button to check it), as does the rearview mirror and the thermometer. I checked all the fused with a 12v light for what that's worth. Maybe I should try pulling every one. Thank you very much for the reply.
Reply With Quote
  #4  
Old 08-16-2017, 12:47 PM
Hillbilly_Hybrid's Avatar
Ridiculously Active Enthusiast
 
Join Date: Sep 2009
Posts: 798
Default Re: Tahoe CEL Won't Illuminate

The CEL is hard wired directly to the engine computer. Either it is not grounded, doubt that, or the computer stopped doing its job.
Reply With Quote
  #5  
Old 08-16-2017, 04:47 PM
Enthusiast
Thread Starter
 
Join Date: Aug 2017
Posts: 3
Default Re: Tahoe CEL Won't Illuminate

I am still able to scan the odb and pull codes as well as freeze frame data, etc. Also checked every fuse with none blown. Any idea on the pinout for the cluster connector? In particular which pins should illuminate the check engine light?
Reply With Quote
  #6  
Old 08-17-2017, 06:45 AM
Hillbilly_Hybrid's Avatar
Ridiculously Active Enthusiast
 
Join Date: Sep 2009
Posts: 798
Default Re: Tahoe CEL Won't Illuminate

No I don't know which pin it is.
Reply With Quote
  #7  
Old 08-17-2017, 09:53 AM
Ridiculously Active Enthusiast

 
Join Date: Sep 2014
Location: Mesa, AZ
Posts: 1,793
Default Re: Tahoe CEL Won't Illuminate

LED or bulb inop?
Reply With Quote
 
 
Reply

Related Topics
Thread Topic Starter Forum Replies Last Post
08 tahoe hybrid won't start with key but starts with remote La Ma GM Hybrid Trucks, Cadillac Escalade Hybrid, Chevrolet Tahoe Hybrid & GMC Yukon Hybrid 9 09-13-2014 11:36 AM
HCH I - throwing a CEL and a IMA light carbnjunkie Honda Civic Hybrid 12 01-30-2008 12:30 PM
Multi Cylinder Misfire CEL backfire still there CaptJackSparrow Honda Accord Hybrid 4 12-09-2007 07:35 AM
My CEL light problems continue Run_n_Late Honda Accord Hybrid 2 10-08-2007 01:36 PM
Americas First Lithium I-Cel Powered R Car Jason Hybrid & Related News 0 04-06-2005 05:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 07:55 PM.